Cannot achieve lock with Streamer

Using USB isolation for audio
Post Reply
Arjay
Posts: 8
Joined: April 29th, 2021, 6:39 pm

Cannot achieve lock with Streamer

Post by Arjay »

Have been using a 7055-C successfully (up to dsd512) between MacBook Pro and May DAC using intona reference.
Upon replacing computer with Auralic Aries G1 streamer the 7055-C does not "lock" the green LED blinks. Streamer says "lost connection." Taking the 7055-C out restores connection and playback.
Strangely the DAC displays correct track resolution.

Tried to use a power supply, but it just beeps still with no lock.

Please Advise,
Ray

cyber
Posts: 13
Joined: May 16th, 2020, 12:05 am

Re: Cannot achieve lock with Streamer

Post by cyber »

Please change power on schedule, or plug in and plug out usb cable , maybe it will be connected, It's not intone problem

Arjay
Posts: 8
Joined: April 29th, 2021, 6:39 pm

Re: Cannot achieve lock with Streamer

Post by Arjay »

Cyber, Thanks for your reply. Indeed I have disconnected and reconnected both usb cables at both ends AND have turned off, unplugged, reinserted power and restarted both units.
I am not sure what "change power on schedule" means.
I am concerned there may be compatibility issues with the Aries since problems started after its installation.

Arjay
Posts: 8
Joined: April 29th, 2021, 6:39 pm

Re: Cannot achieve lock with Streamer

Post by Arjay »

Upon further investigation, once the 7055-C is installed the Aries no longer "finds" or "sees" the May and limits trying to connect via its internal USB protocols, And, these internal protocols do not pass audio signal through the intona to the DAC.

Arjay
Posts: 8
Joined: April 29th, 2021, 6:39 pm

Re: Cannot achieve lock with Streamer

Post by Arjay »

Anyone? Thoughts? Daniel?

Daniel (Intona)
Posts: 76
Joined: May 6th, 2020, 8:29 am

Re: Cannot achieve lock with Streamer

Post by Daniel (Intona) »

They are using an off-the-shelf XMOS chip.
aries-g1-detail.jpeg
XMOS supplies the USB audio classes (UAC 2.0) to their customers free of charge since ever. There were many, many bugs in this and there is no straight forward USB compliance testing.
But doing transparent USB isolation requires 100% USB compliance from both host and device. One of the older bugs seems to match your issue.

To my knowledge, there are two ways to fix this:
1. ask the vendor of your DAC for an update of the XMOS firmware.
2. add an USB hub between the DAC and the isolator. (Because the hub enumerates to the host, it will obtain separate timing resources for both handshaking and data transfer.)
Daniel (Intona)

Arjay
Posts: 8
Joined: April 29th, 2021, 6:39 pm

Re: Cannot achieve lock with Streamer

Post by Arjay »

Thank You!
I will investigate your recommendations.
Ray

Arjay
Posts: 8
Joined: April 29th, 2021, 6:39 pm

Re: Cannot achieve lock with Streamer

Post by Arjay »

Daniel,
I contacted Auralic who said the installed software is the current and latest available. They also provided some suggestions in terms of start-up sequence of both devices with Isolator in-line. No improvement.
I suspect a fault lies within the Aries that renders it incompatible with the Isolator. As an aside, I tried the Aries with two other DACs and in each case there was no connection when the Intona was in place. Removing the Intona restored Aries ability to "see" and connect to any of the now 3 DACs I have tried. It seems the Aries is not compatible with the Isolator.
Using computers MBPro or Windows based desktop as source, both work fine with Isolator in-line.
I did not have a USB hub to insert between isolator and DAC, but I ordered one to try. I am a bit concerned the extra device and connections will defeat, at least partially, the purpose and function of the Isolator.
Feel free to correct me on this "concern."
Thank you again for your response and advice,
Ray

Arjay
Posts: 8
Joined: April 29th, 2021, 6:39 pm

Re: Cannot achieve lock with Streamer

Post by Arjay »

Insertion of hub between Isolator and DAC no help.

Daniel (Intona)
Posts: 76
Joined: May 6th, 2020, 8:29 am

Re: Cannot achieve lock with Streamer

Post by Daniel (Intona) »

Please try the hub between MBPro and Isolator.
Daniel (Intona)

Arjay
Posts: 8
Joined: April 29th, 2021, 6:39 pm

Re: Cannot achieve lock with Streamer

Post by Arjay »

Thanks Daniel,
I am done trying for now.
Maybe Auralic will upgrade the xmos software with next upgrade.
Thanks for your assistance.
Ray

crazywoo
Posts: 3
Joined: May 15th, 2021, 4:24 am

Re: Cannot achieve lock with Streamer

Post by crazywoo »

i have the same issue running rpi4 ropieexl as roonbridge, intona cannot lock the signal sending from rpi4 while another windows laptop pc have no problem (led status green solid color without blinking)

The same rpi4 and cables works with iFi nano USB before, i just wonder is there any turnaround solution here ? Thanks.

Daniel (Intona)
Posts: 76
Joined: May 6th, 2020, 8:29 am

Re: Cannot achieve lock with Streamer

Post by Daniel (Intona) »

Didn't hear of any rpi related issues. I will try it with some rpi when I am in the lab next time.
Daniel (Intona)

crazywoo
Posts: 3
Joined: May 15th, 2021, 4:24 am

Re: Cannot achieve lock with Streamer

Post by crazywoo »

crazywoo wrote: May 15th, 2021, 4:26 am i have the same issue running rpi4 ropieexl as roonbridge, intona cannot lock the signal sending from rpi4 while another windows laptop pc have no problem (led status green solid color without blinking)

The same rpi4 and cables works with iFi nano USB before, i just wonder is there any turnaround solution here ? Thanks.
I just did a test, when adding iFi nano USB between rpi4 and isolator, (Rpi4 <-> iFi USB <-> USB isolator <-> USB DAC) it will work without any problem. That's strange.

Daniel (Intona)
Posts: 76
Joined: May 6th, 2020, 8:29 am

Re: Cannot achieve lock with Streamer

Post by Daniel (Intona) »

That points me that the rpi4 does not deliver enough power for the isolator. Is the DAC USB-powered? Which isolator model do you have?
Daniel (Intona)

crazywoo
Posts: 3
Joined: May 15th, 2021, 4:24 am

Re: Cannot achieve lock with Streamer

Post by crazywoo »

Daniel (Intona) wrote: May 21st, 2021, 8:52 pm That points me that the rpi4 does not deliver enough power for the isolator. Is the DAC USB-powered? Which isolator model do you have?
DAC is Chord Qutest and have seperate USB power supply for it. i have usb 3.0 1kv version one.

Softsounds
Posts: 3
Joined: June 5th, 2021, 9:26 am

Re: Cannot achieve lock with Streamer

Post by Softsounds »

Daniel (Intona) wrote: May 21st, 2021, 8:52 pm That points me that the rpi4 does not deliver enough power for the isolator. Is the DAC USB-powered? Which isolator model do you have?
I am using the Model 7055-C and it has worked flawlessly via the Allo Usbridge Signature which uses a Raspberry Pi 3, as well as via a Mac. However I recently upgraded to a Pi4 B and running either Ropieee or VitOS and it does not lock.

I have also tried a separate 5v 3A power supply and it does not solve the problem.

Wondering if there is a solution yet for this.

Daniel (Intona)
Posts: 76
Joined: May 6th, 2020, 8:29 am

Re: Cannot achieve lock with Streamer

Post by Daniel (Intona) »

I am currently awaiting a Pi4B. I will have a look into the data transfer asap.
Daniel (Intona)

Post Reply